JavaScript Required

Camtasia Relay's website requires the use of JavaScript.

Either your browser does not support JavaScript or you have turned off the JavaScript option. Your browser must be able to run JavaScript in order for you to access the Camtasia Relay Administation website.

Camtasia Relay supports Internet Explorer 7.0+, FireFox 3.0+, and Safari 3.0+.


Internet Explorer Instructions

Internet Explorer
  1. Click "Tools"
  2. Click "Internet Options"
  3. Click the "Security" tab
  4. Click "Trusted sites"
  5. Click "Sites"
  6. Type your server name in the "Add this website to the zone:" textbox and click "Add"
  7. Click "Close", click "Ok"

After you have proceeded with the steps listed above please click here to login.


Firefox Instructions

Firefox
  1. Click "Tools"
  2. Click "Options"
  3. Click the "Content" section
  4. Click the "Enable JavaScript" checkbox
  5. Click "OK"

After you have proceeded with the steps listed above please click here to login.


Safari Instructions

Safari
  1. Click "Safari" on the Mac or click "Edit" on Windows
  2. Click "Preferences"
  3. Click the "Security" section
  4. Click the "Enable JavaScript" checkbox
  5. Close the window

After you have proceeded with the steps listed above please click here to login.